Status Page

Cash Point Closings remain on state PENDING

Resolved
DSFinV-K API
Degraded Performance

Cash Point Closings are currently not processed and remain in the PENDING state.

2022-02-21T10:15:35.377Z
resolved 🎉

The Cash Point Closings are being processed again. We are sorry for the inconvenience.