A subset of TSS instances continues to experience degraded performance resulting in 502 errors which is expected to persist overnight. If affected, please ensure not to block the till and print "TSS not available" on the receipts. Our team is actively working on resolving the issue. Further updates will follow in the morning. We apologize for the disruption.
Posted May 24, 2026 - 20:28 CEST
Update
A subset of TSS instances is still experiencing degraded performance resulting in 502 errors. If affected, please make sure not to block the till and print "TSS not available" on the receipts. Our team is actively working on resolving this issue. We apologize for the disruption.
Posted May 24, 2026 - 13:40 CEST
Identified
Due to issues after today's maintenance operation some TSS instances still experience degraded signing performance. We are currently working on a solution to mitigate this issue.
Posted May 24, 2026 - 12:19 CEST
Investigating
We are currently experiencing degraded performance affecting signing transactions. We are investigating the issue and will provide further updates.